How to Install or Upgrade your POS Terminal Application

IMPORTANT: You must be logged into the computer user account that you want to operate the software application. If you install the software from an admistrator user account on your computer and that is NOT the user account that was actively using the software, you will cause the system to install as a new install and it will not suck / import any of your old settings. PLEASE log into the user account on your computer that normally runs the POS terminal application and then follow the instructions below.

To upgrade or install your POS Terminal Application, the first thing we need to do is close down your current PCS POS terminal completely. Then download the zip archive from the website. Click on the link below to get started:

http://www.partycentersoftware.com/software/download

  • The current version of the POS Terminal will be the first link you see on the site.

 

 

The following instructions cover how to download and open the file in Internet Explorer. If you use another browser and/or know what you're doing, skip the next 2 screens.

  • After clicking on the link, select the "Save" option.

 

 

  • When the download finishes, use the "Open Folder" button to navigate to your default downloads folder.

 

 

  • The application installer is packaged in a zip archive, in laymen's terms, think of it like opening an envelope. Right click on the POSTerminal[version].zip file and select "Extract All..."

 

 

  • By default, it will create a folder in the folder you're already in and extract the files there. Leave "Show extracted files when complete" checked, then hit the "Extract" button.

 

 

  • Once in the new folder, right click on the PosTerminal.exe file and run as administrator to begin the installation. NOTE: Make sure you have closed down and exited from the older version of the POS Terminal before you install.

 

 

NOTE: The POS Terminal application depends on some development libraries from Microsoft. You may or may not get a screen asking you to install Visual C++ or .NET libraries. This is an automatic process and you just need to hit the Install button at the bottom of this Window. This is normal. The regular application installation will follow.

If you are on Windows 8 and receive errors that .NET 2.0 or 3.5 are not available, consult the following help document from Microsoft.

  • Continue through the prompts of the installation process.

 

 

 

 

 

 

 

 

  • Double click on the "Point of Sale Terminal" link on your Desktop.

 

 

NOTE: If you get a black box telling you that the program could not complete pre-flight conditions, don't worry. Try opening the program a second time and it should open without issue. If problems persist, contact customer support at (916) 634-1166, or +61 2 8294 5110 AUS, +44 116 326 0870 UK.

  • If this is a first install, or an upgrade of a much older version, the application may prompt you for some information. Give the POS station a name and enter in the URL of your PartyCenterSoftware. Do not type in the https:// as it is already implied.

 

 

  • If you are not automatically prompted by a Settings screen, it can be accessed from the icon in the top left of the application.

 

 

  • If no hardware information exists, you will be prompted to select your devices. Additionally, you can see what version of the software you are running at the bottom of the window.

 

 

Beyond here, you can log into the software and continue using it as normal.

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.